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In the first lesson, you will 

create a simple 

dashboard to combine 

two sets of data and then 

analyze the results using 

interactive reports.  

 

This tutorial should take 

40-60  minutes to 

complete.   
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Lesson OverviewLesson OverviewLesson OverviewLesson Overview    
In this introduction, we will cover the following functionality and concepts: 

• Launch, edit and save new Proto dashboards. 

• Insert and connect basic Modules and Components to create new functionality. 

• Create new steps in a workflow dashboard. 

• Merge two datasets, filter data, enrich data and present data in dynamic reports. 

 
You will be building upon a dashboard provided with the lesson, which has two related 
sets of data embedded in it. In this lesson we’ll cover how to combine these data sets, 
add a simple filter to eliminate some of the data, and then experiment with some 
dynamic reports like a drill down pie graph, an aggregation report and an XY scatter 
plot. The data used in this lesson is from a mock stock portfolio, but the techniques you 
learn should apply to combining and analyzing any related data.  
 
Before you start this lesson, you will need to have installed Proto Professional Version 
1.9 and downloaded the lesson files from the Proto website. The lesson files can be 
downloaded in a zipped format from Proto’s website at 
http://www.protosw.com/devcenterhttp://www.protosw.com/devcenterhttp://www.protosw.com/devcenterhttp://www.protosw.com/devcenter 
 
Before jumping into the tutorial, you might want to take a quick moment to explore and 
understand the Proto dashboard that you will be creating. To do so, 

1111 Locate the folder named “Lesson 01” in the folder titled “Proto Getting Started 
Lessons.” 

2222 Open the file named “Lesson 01 (Completed) - Stock Portfolio Analysis.proto.”  

3333 Click “OK” if prompted that the file has VBA macros.  

    

NoteNoteNoteNote: : : : When you open a Proto file that uses VBA, you will be prompted with a 
Security Warning dialog box. You should always be careful when opening files from 
someone you don’t know. However, you can repress this warning from showing in 
the future. To do so, go to Proto’s application settings by choosing Tools > Options 
from the application menu bar. Then check the box in the “Security and Privacy” 
section titled “Don’t show VBA Warning dialog on load.” 

 

To begin building the dashboard, first open the lesson file and save a copy as  
“Stock Portfolio Analysis.proto.” 

1111 Locate the folder named “Lesson 01” in the folder titled “Proto Getting Started 
Lessons.” 

2222 Open the file named “Lesson 01 (Begin) - Stock Portfolio Analysis.proto” by double-
clicking on the file. 

3333 Save this Proto dashboard with a new name in the “Lesson 01” folder. To do so, 
select File > Save As from the application menu bar. Then browse to the 
appropriate location and save the file as “Stock Portfolio Analysis.proto.” 
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Exploring theExploring theExploring theExploring the    Lesson FileLesson FileLesson FileLesson File    
When you open the lesson file, Proto will create a window with a menu bar, some 
clickable steps on the left and content area on the right with a table in it. Try clicking 
between the two steps to see the content area change: 

 
 

This window is called the ViewerViewerViewerViewer, and end-users of dashboards work within this screen 
to click through data integration, cleaning, analysis and reporting steps. The Viewer is 
also where you as the dashboard developer will adjust the position and size of controls 
on the screen. 

 

Every Proto dashboard is represented in two separate interfaces: the Viewer and the 
BuilderBuilderBuilderBuilder. You will define the functionality of the dashboard in the Builder.  

 

For a comprehensive introduction to the Proto Environment, please watch the video, An 
Introduction to Proto, available on the Developer Center. If you are feeling bold or just 
like gain an overview through direct experience, you can charge ahead with the lesson 
and probably pick things up as you go. 

 

Now switch over to the Builder and familiarize yourself with that window. 

4444 Click Control + ~Control + ~Control + ~Control + ~    from the keyboard or select View > Builder from the menu bar. 

 
 

In the Builder window, you will see central area bordered by a toolbar on top, a help 
pane on the right and some additional buttons. For now, focus on the middle area with 
the two ComponentComponentComponentComponentssss on it named “Sample Portfolio Returns Data (10-25-2006)” and 
“Sample Security Attributes.” These Components correspond directly to the two steps 
on the Viewer as shown below: 



 4444    
Lesson 01 

GGGGeeeettttttttiiiinnnngggg    SSSSttttaaaarrrrtttteeeedddd    wwwwiiiitttthhhh    PPPPrrrroooottttoooo 

    
    

Some Context: Some Context: Some Context: Some Context: MultiMultiMultiMulti----step Workflows instep Workflows instep Workflows instep Workflows in Proto  Proto  Proto  Proto     
The introductory lessons are intended to help you understand the Proto paradigm by 
way of hands-on examples. Hopefully you have a decent grasp of the product 
architecture, development environment and intended use from watching  An 
Introduction to Proto.  However, it is worth spending a few extra minutes to draw a 
comparison between Proto Components, sections of the Viewer called workflow steps, 
and a particularly common and problematic data analysis scenario that is routinely 
carried out in Excel: long, repetitive, manual tasks to integrate and analyze disparate 
sources of data. 

Workflow StepsWorkflow StepsWorkflow StepsWorkflow Steps and Components and Components and Components and Components    

In Proto, you can create guided workflows in which each “step” of the workflow is 
shown by clicking through a list of named buttons on the left-hand side of the Viewer. 
The steps don’t necessarily have to represent a sequential process, but they do divide 
the functionality of a Proto dashboard into discrete sections. Under the hood, each step 
is represented by a separate Component on the Builder. And as we’ll see, Components 
do a nice job of dividing and encapsulating functionality in Proto as well. Together, 
Components and workflow steps make it fast and easy to assemble new dashboards 
that guide end users through common data integration, analysis and reporting tasks. 

 

We’ll talk later about how you build, store and share Components, but first let’s look at 
some examples of Components, how they’re used and how that relates back to step-by-
step workflows. Components can: 

• Get data (read data in, query data dynamically, get data input from users) 

• Do stuff with data (calculate, filter, join, clean, analyze, etc.) 

• Present the data on screen (dashboard, dynamic analysis, visualization, tables, etc) 

• Output the data and take action (write to Excel, update databases, run scripts, etc.) 

• Do all kinds of other things. 

 

Specific examples include: 

• Get current pipeline data from a sales database 

• Calculate the Month-to-Date P&L for a set of transactions 
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• Show a portfolio manager a summary of his Top 10 and Bottom 10 holdings 

• Write correct Security IDs back to a database after a user types overrides into Proto 

• Send an email, write an HTML file to a directory, etc. 

 

Some Components serve very simple functions like deleting columns from a dataset or 
providing the user with a Listbox to select an item, and some Components perform 
more sophisticated operations and contain many user interface controls.  

 

Components are added to the Builder, connected in sequence to define the 
functionality of the dashboard, and grouped together to create new Components. On 
the Viewer, Components can optionally be exposed as steps, sub-steps and other 
groups with the user interface controls positioned and sized as needed. 

The Parallel The Parallel The Parallel The Parallel betweenbetweenbetweenbetween Workflow Steps and Manual Excel Processes Workflow Steps and Manual Excel Processes Workflow Steps and Manual Excel Processes Workflow Steps and Manual Excel Processes    

In Excel, users frequently describe repetitive workflows in a series of actions that they 
perform such as: 

1111 First I get the latest data from our accounting system by opening the “POS-
Current.CSV” file in Excel and then copying and pasting that data into the tab in my 
workbook called “Positions.”  

2222 Then I delete all of the columns except for Date, Security ID, Quantity, etc. 

3333 Then I type over the foreign Security IDs that I know are wrong. 

4444 Then I create a VLOOKUP formula to look up the Sector, Market Cap, etc. from 
another tab in the workbook that links to our market data source.  

5555 And the list goes on… 

 

When we design a dashboard in Proto to parallel an existing analysis workflow, we start 
by identifying source data sets, and writing down what needs to happen to them in 
order to arrive at results. The list of abstract steps may start out very broad like this: 

1111 Get latest data from a daily CSV 

2222 Remove unnecessary columns  

3333 Override certain known incorrect values 

4444 Enrich the data with values from another data set 

5555 Etc. 

 

And then as we focus on a particular step, they become more detailed: 

1111 Get latest data from a daily CSV 

1.1 Provide the user with a button to pop-up a File Browser dialog box to select a 
file. 

1.2 Read in the CSV data with another Component that takes a file path to a CSV 
and outputs a dataset 

1.3 Display the new data in a Table 

1.4 Etc. 
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These steps, or operations, that need to happen to the data in sequence, are eventually 
translated into Components. The vast majority of Components will be hidden in the 
Builder, and end-users will only interact with controls that are necessary to direct the 
flow of operations, enter data, make decisions and see results. Once all these 
Components are assembled together, the workflow is captured in a dashboard with 
clear steps that included the end-user at the necessary points to complete the data 
integration, cleaning, analysis and output.  

Data Flow in Proto Data Flow in Proto Data Flow in Proto Data Flow in Proto     

As described above, Components define a series of operations, user interfaces and 
other processes that act on data to achieve a result. Clearly data must flow between 
Components in some form for this all to work. A full discussion of data management in 
Proto is beyond the scope of this lesson, but a small set of concepts and corresponding 
vocabulary will help you develop a deeper understanding of Proto as you go through 
these exercises.  

 

There are two basic types of data in Proto. 

• Single values like dates, numbers, text values, etc. 

• Tables of data that store rows and columns of data (single values and other tables) 

 

Both of these types of data flow across one-way connections from one Component to 
another. Though the data is not actually copied at every step, each Component can 
behave as though it has a full copy of the data.  

 

Tabular data in Proto is contained in EntrysetEntrysetEntrysetEntrysetssss. An Entryset is like a “table” and has 
“rows” of data called EntriesEntriesEntriesEntries    and “columns” of data called AttributesAttributesAttributesAttributes. In the tutorials 
you may see reference both to columns and attributes as well as rows and entries. We 
sometimes use these terms interchangeably when discussing portions of a dataset that 
has rows and columns.  
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Merging the Two DatasMerging the Two DatasMerging the Two DatasMerging the Two Datasetsetsetsets    
Let’s return to the Viewer to inspect the two sets of data that we will work with. The first 
set of data is numerical values representing profit & loss associated with each security 
in a stock portfolio. The second set of data is a set of qualitative attributes associated 
with each of the securities. If you are not familiar with the financial terms used, you can 
just think of these two sets of data as being generic “items” with some numerical 
values and some categorizations. For example, the data could be quarterly sales per 
account, and the categorizations could be the account rep, account region, account 
type, etc. 

 

These data sets were previously pulled into Proto and saved along with the lesson file 
so that you do not have to import your own data to work with. This will help keep the 
screenshots and descriptions you see in this lesson consistent with what you see on 
your screen. In a real workflow dashboard, “Get Data” steps could allow a user to pick a 
new Excel file, refresh a query from a database, paste data into a table, read in a CSV 
or get data in a variety of other ways. 

 

Additionally, these data sets are already clean and well-formed so that you can 
combine and use them immediately. This is rarely the case with real-world disparate 
data sources, but for the purpose of these lessons, assume that the two data sets 
already have had the benefit of cleaning and normalization steps. Most of those steps 
would be automated operations to add and delete columns, replace values, etc. and 
others would likely involve the end-user to check the inputs, add data, correct 
exceptions and typos, etc.  

 

During this lesson, we will mostly rely on Components to incorporate more 
sophisticated functionality and introduce the concept of workflow steps. However, 
combining data is a fundamental and common process in Proto, and we will use a 
primitive Module, called the Entryset Join Module, to merge the two sample data 
sources. In the next couple sections you’ll learn how to: 

I.I.I.I. Add the Entryset Join Module to the Builder (referred to herein as the Join Module). 

II.II.II.II. Make connections from the sample data Components to the Join Module. 

III.III.III.III. Configure the Join Module settings through its Property Panel to combine the 
columns of the two datasets based on related columns of data. 

IV.IV.IV.IV. View the Output of the Join Module. 

 

Add the Join Add the Join Add the Join Add the Join Module Module Module Module to the Builder.to the Builder.to the Builder.to the Builder.    

You can add primitive modules to the Builder in two ways: 
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1111 Use the toolbar at the top of the Builder window 

 
 

2222 Or right-click anywhere on the background of the Builder and select the primitive 
module from the “Insert Module” menu: 

 
 

 

Try adding the Join Module to the Builder now. After you insert it, your Builder window 
should look similar to the screenshot below. Note that nothing has changed in the 
Viewer, because the Join Module does not expose a user interface control. 

 
 

NoteNoteNoteNote: Because this is the first time you have inserted a Join Module in this dashboard, 
the name will be appended with the number “1.” If you were to add another Join 
Module, it would be appended with the number “2”, and so on. 

    

Make Make Make Make CCCConnections from the onnections from the onnections from the onnections from the SSSSample ample ample ample Data Data Data Data to the Join to the Join to the Join to the Join ModuleModuleModuleModule    

In the next series of steps you will make two Connections that will send data from the 
sample data Components to the Join Module. 

 

1111 Go to the Builder 
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2222 Click on the small blue arrow on the right side of the “Sample Portfolio Returns 
Data (10-25-2006)” Component to select an output connector from this 
Component.  

 
 

3333 Click on the menu item titled “Sample Portfolio Returns” to start the Connection. A 
blue line will now follow the mouse as shown below. 

 
 

4444 Click on the small blue arrow on the left side of the Join Module to select an input 
connector to this Module. 

 
 

5555 Click on the “Set Left Entryset” input to complete this Connection. 

 

To save space, throughout the rest of the Lessons we will describe Connections without 
showing the screenshots using the following notation: 

FromFromFromFrom:    Module or Component name 

OutputOutputOutputOutput:  Output Name 

ToToToTo:  Module or Component Name 

InputInputInputInput:  Input Name  

 

For example, you just made the following connection: 



 11110000    
Lesson 01 

GGGGeeeettttttttiiiinnnngggg    SSSSttttaaaarrrrtttteeeedddd    wwwwiiiitttthhhh    PPPPrrrroooottttoooo 

FromFromFromFrom:   Sample Portfolio Returns Data (10-25-2006) 

OutputOutputOutputOutput:  Sample Portfolio Returns 

ToToToTo:  Entryset Join 1 

InputInputInputInput:  Entryset Join Connectors > Set Left Entryset  

 

6666 Now connect from the Sample Security Attributes data to the Join Module.  

FromFromFromFrom:   Sample Security Attributes 

OutputOutputOutputOutput:  Sample Security Attributes 

ToToToTo:  Entryset Join 1 

InputInputInputInput:  Entryset Join Connectors > Set Right Entryset  

 

7777 When you make the second Connection, the Join Module will error with the 
message, “No matching columns have been specified.”  When you made the 
second Connection, the Join Module tried to process its inputs, combining them 
into a merged output Entryset. However, this failed because we have not told the 
Join Module which columns in the two inputs are related. We will do that in the 
Property Panel shortly. 

 
 

 

What What What What DDDDoes the Join Module Do?oes the Join Module Do?oes the Join Module Do?oes the Join Module Do?    

The Join Module takes two Entrysets as inputs, and combines the columns to create a 
single Entryset output. If you are familiar with database operations, the Join Module 
does the equivalent of a Left Outer Join. If you are familiar with the VLOOKUP function 
in Excel, you can think of the Join Module as adding all of the columns in a lookup table 
to the destination. If you are not familiar with either of those operations, it may be 
easiest to experiment with the Join Module on your own to understand its functionality.  

 

The Join Module operates on two Entryset inputs, a Left Entryset and a Right Entryset. 
All of the new columns of the Right Entryset will be added to the Left Entryset. To 
determine which row of data in the Right Entryset should be added next to a row in the 
Left Entryset, a set of unique identifiers is compared in each of the two Entrysets.  

 

In the example below, the common identifier is the letter “A”, “B” or “C” found in the 
“Left ID” column in the Left Entryset and the “Right ID” column in the Right Entryset. 
Note in the example below that the rows with “A” and “B” in the Left Entryset find 
matching rows in the Right Entryset, but the row with “C” does not and the cells in the 
resulting Entryset are empty. 
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In more complex situations, there may be multiple columns that together represent the 
unique identity of a given row. For example, the Join Module may relate the rows of two 
Entrysets by matching two columns, “First Name” and “Last Name,” in the Left Entryset 
with two columns, “Name” and “Surname,” from the Right Entryset.  

 

The Property Panel of the Join Module allows you to specify as many relationships as 
needed to properly relate, and merge two data sets. 

 

Configure the Configure the Configure the Configure the Join ModuleJoin ModuleJoin ModuleJoin Module    

Now we’ll configure the Join Module so that it correctly merges the two sets of portfolio 
data. To do so we will open the Property Panel and specify a relationship between the 
Left Entryset and Right Entryset in the section titled “Matching Columns.”  

 

1111 Double-click on the Join Module or right-click and select “Properties” from the 
context menu to open the Join Module’s Property Panel. 
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2222 To add a Matching Columns constraint, click the “Add” button in the Matching 
Columns section of the Property Panel. 

3333 Next, click once on the empty cell below the header “Left Column” in the 
configuration table, and you will see a Drop-down list appear. 

 
 

4444 Select “Ticker” for the Left Column and “Ticker” for the Right Column using the 
Drop-down lists. 

 
 
Note:Note:Note:Note: The names of the related columns do not have to be the same. For example 
the column may be called “Ticker” in one Entryset and “Stock Symbol” in another. 
 

5555 Click “Save” to save your changes and close the Property Panel. 

 
 

 



 11113333    
Lesson 01 

GGGGeeeettttttttiiiinnnngggg    SSSSttttaaaarrrrtttteeeedddd    wwwwiiiitttthhhh    PPPPrrrroooottttoooo 

Add aAdd aAdd aAdd a Table Report Component to View the Output  Table Report Component to View the Output  Table Report Component to View the Output  Table Report Component to View the Output fromfromfromfrom the Join  the Join  the Join  the Join ModuleModuleModuleModule    

Later on, we will build reporting Components and work with primitive Modules like 
Tables to view and edit Entrysets. However for now, we will use a pre-built Component 
called the Table Report to keep moving ahead and further illustrate the connection 
between Components and workflow steps. 

 

The Getting Started Components used in this Lesson are available to download from 
the Developer Center on the Proto website as “All Getting Started Components.zip.” If 
you downloaded “All Lessons, MiniTutorials and associated files.zp” you should already 
have the necessary files. If you don’t have the Getting Started Components, download 
them now from http://www.protosw.com/devcenter.  

 

1111 On the background of the Builder window, right-click and then select “Insert from 
Folder…” from the context menu. 

  
 

2222 Browse to the following folder in the Getting Started Components directory:  
         .. .. .. ..\\\\Getting Started ComponentsGetting Started ComponentsGetting Started ComponentsGetting Started Components\\\\PPPPresentation and Analysisresentation and Analysisresentation and Analysisresentation and Analysis 

 

3333 Select the file: 
     Table Report.proto 

4444 Click the “Open” button on the Open Module dialog window. 
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5555 The Table Report will be added to the Builder as shown below.  

 
 

Throughout the rest of the lessons, directions to insert a Component will appear in 
the following format: 

LocationLocationLocationLocation:  ..\Getting Started Components\Presentation and Analysis 

ComponentComponentComponentComponent: Table Report.proto  

 
NoteNoteNoteNote: You can change the name of any Module (both primitive Modules and 
Components) by double-clicking on it in the Builder and typing in a new name in the 
Label field on the General tab in the Property Panel.  

 

6666 Now switch to the Viewer by selecting “View > Viewer” from the Application menu 
or clicking the “Switch to Viewer” icon in the bottom right hand side of the Builder.  

7777 Click between the two workflow steps and note that the Table Report Component 
always stays on top and is not part of the workflow structure yet. We’ll change that 
in the next section. 
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Note:Note:Note:Note: There is already data in the Table Report Component. This data was saved 
along with the Component when it was created or last saved. When we inserted the 
Component into a new dashboard, the old data came along with it. When we make 
connections to the Table Report Component in the Builder, the old data will be 
flushed out by the output Entryset from the Join Module, and the data shown in the 
table will update. 

 

Make the Make the Make the Make the Table Report ComponentTable Report ComponentTable Report ComponentTable Report Component a Workflow Step a Workflow Step a Workflow Step a Workflow Step    

1111 Return to the Builder by selecting “View > Builder” from the Application menu. 

2222 Double-click anywhere on the white background area of the Builder, and a Property 
Panel will be shown for the dashboard you are building.  

3333 Click on the Workflow Steps tab in the Property Panel 

 
 

4444 Note that the Workflow Steps are already enabled, and there is a step defined for 
each of the sample data Components. 

5555 Click the button titled “Add” at the bottom of the list of workflow steps 

 
 

6666 Proto will automatically add a workflow step as long as there is still an unmapped 
Component on the Builder. If all the Components are mapped to workflow steps, 
the “Add” button will have no effect. In this case the Table Report Component will 
be detected and added. Rename the step to “Table Report” by double-clicking in 
the Name column and changing the text. 

 
 

7777 Click Save at the bottom of the Property Panel. 
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8888 Return to the Viewer, and click on each of the steps once again. Notice that now 
the visibility of the Table Report Component is being controlled by the workflow 
step buttons. 

 
 

Connect the Join Module to the Table Report ComponentConnect the Join Module to the Table Report ComponentConnect the Join Module to the Table Report ComponentConnect the Join Module to the Table Report Component    

1111 Return once more to the Builder. 

2222 Then make a Connection from the Join Module to the Table Report Component.  

FromFromFromFrom:   Entryset Join 1 

OutputOutputOutputOutput:  Entryset Join Connectors > Get Joined Entryset 

ToToToTo:  Table Report 1 

InputInputInputInput:  Input Entyrset  

 

3333 Your Builder window should look similar to the screenshot below. 
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4444 Go back to the Viewer and confirm that the Table Report Component now shows 
the merged data. 

 
 

 

 

Congratulations! You are through the basic principles of the Viewer, the Builder, 
Modules, Connections, and creating workflow steps. 

 

In the next few pages, you’ll see how to add and configure more sophisticated 
Components to analyze and explore the merged data set. 

 

Add a Add a Add a Add a Component to Filter Out a Row of DataComponent to Filter Out a Row of DataComponent to Filter Out a Row of DataComponent to Filter Out a Row of Data    
In the next couple of steps, we’ll add a filtering Component to eliminate an unwanted 
row from the merged data set. Unlike the Table Report Component, the filtering 
Component needs to be configured to be useful. In particular we need to specify the 
conditions we want to use to filter out rows of data. We’ll cover two techniques to 
configure Components.  

I.I.I.I. You can display the Component’s user interface in a pop-up window, make 
necessary configuration settings, and then close the pop-up window. Once you 
close the pop-up window, the Component will not be shown to the end user or 
displayed as a workflow step. If you ever need to change its configuration you can 
locate it in the Builder, pop-up its user interface, make changes, and close it again. 
This mirrors the process of configuring a primitive Module through its Property 
Panel, as you did with the Join Module. 

II.II.II.II. You can display the Component as a workflow step, embed it elsewhere in the 
Viewer or embed it in another Component. When you do this, end users will be able 
to see the Component and interact with it as needed.  
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Some Components are pretty clearly user-facing, like a graphing Component or the 
Table Report you just used. Other Components need to be configured once, but aren’t 
likely to change thereafter or require user input. The filtering Component doesn’t clearly 
fall into one camp or the other. In some applications the filtering criteria will never 
change, and in other applications an end user may want to be able to change the 
criteria interactively as part of an analytical process. Fortunately you can make a 
judgment call to do what’s best for end users, and as you’ll see later on, it’s easy to 
change how a Component is presented. 

 

Add the filtering Add the filtering Add the filtering Add the filtering CCCComponent to the Builderomponent to the Builderomponent to the Builderomponent to the Builder 

1111 Go to the Builder, right-click on the background and select “Insert from Folder…”  

2222 Browse through the Getting Started Components and insert the filtering 
Component: 

LocationLocationLocationLocation:  ..\Getting Started Components\Do Stuff with Data\Sort and Filter Data 

ComponentComponentComponentComponent: Filter Data (Generic).proto 

 

 
 

 

 

Delete and remake Connections to incorporate the Filter DataDelete and remake Connections to incorporate the Filter DataDelete and remake Connections to incorporate the Filter DataDelete and remake Connections to incorporate the Filter Data Component  Component  Component  Component  

1111 Delete the Connection between the Join Module and the Table Report Component 
by right-clicking on the Connection and selecting “Clear All Connections” or clicking 
on the Connection once, turning it light blue, and then hitting the Delete key on 
your keyboard. 
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2222 Now position the Filter Data Component between the Join Module and the Table 
Report Component. 

 
 

3333 Then make the following Connections: 

FromFromFromFrom:   Entryset Join 1 

OutputOutputOutputOutput:  Entryset Join Connectors > Get Joined Entryset 

ToToToTo:  Filter Data (Generic) 1 

InputInputInputInput:  Input Entryset  

 

FromFromFromFrom:   Filter Data (Generic) 1 

OutputOutputOutputOutput:  Filtered Entryset 

ToToToTo:  Table Report 1 

InputInputInputInput:  Input Entryset  

 

Your Builder window should now look like this. 

 
 

    

Open Open Open Open the Filter Component the Filter Component the Filter Component the Filter Component in in in in a Popa Popa Popa Pop----up Windowup Windowup Windowup Window 

To configure a Component’s functionality through a pop-up window, you will first have 
to set its presentation style to “Pop up.” A Component can present its user interface in 
a few different ways, and you can change the presentation style through the 
Component’s Property Panel. 



 22220000    
Lesson 01 

GGGGeeeettttttttiiiinnnngggg    SSSSttttaaaarrrrtttteeeedddd    wwwwiiiitttthhhh    PPPPrrrroooottttoooo 

4444 Open the Filter Data Component’s Property Panel by double-clicking on the Filter 
Data Component icon or right-clicking and selecting “Properties…” 

 
 

5555 If the Viewer Presentation selection is not already set to “Pop up,” make that 
selection now: 

 
 

6666 Click Save to close the Property Panel and save your changes. 

7777 Go to the Viewer and confirm that the Filter Data Component is not visible on the 
Viewer. 

8888 Return to the Builder and “Pop up” the Filter Data Component by right-clicking on it 
and selecting “Open Pop up Viewer.”  
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9999 The user interface for the Component will open in a detached, pop-up Viewer. You 
can close and resize this window independently of the primary Viewer window. 

 
 

 

    

Configure the FilterConfigure the FilterConfigure the FilterConfigure the Filter Data Component Data Component Data Component Data Component 

The Filter Data Component allows you to set filtering criteria to filter out certain rows 
from an Entryset. Behind the scenes, it is a very simple Component that wraps up a 
primitive Entryset Filter Module with some logic to display how many rows were filtered 
out of the Entryset. You will learn how to build Components out of primitive Modules 
and other Components in later lessons.  

 

We will configure the Filter Component to eliminate the USD position from the portfolio 
data (the row where the Ticker is “USD”). However you can experiment with other 
filtering criteria on your own.  

 

1111 Click the button named “Edit Filter Parameters.”  
 
Note:Note:Note:Note: This button is connected in the Builder so that it launches the Property Panel 
for the primitive Filter Module that is contained inside the Filter Component. This 
Property Panel is similar to the Property Panel for the Entryset Join Module that you 
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configured earlier in this Lesson, or the generic Property Panel you opened for this 
Component to change its presentation style. It is a built-in Proto Property Panel, 
and is unrelated to the “pop-up” functionality of the Filter Data Component. Certain 
primitive Modules have user-friendly Property Panels, and from time to time you 
may want to expose them via buttons on the Viewer as illustrated by this example. 
 

2222 Click the “Add” button to create a new condition. 

 
 

3333 In the “Edit Conditions” section, set the first Listbox to “Ticker” to filter on that 
attribute of the Entryset. 

 
 

4444 Set the next Listbox to “Text” which allows you to define text based filtering 
comparisons like “Starts with” or “Contains.” 

 
 

5555 Then click on the Checkbox named “Where” which will enable additional 
conditions. 

 
 

6666 Configure the next section to say “The Text does Not Equal to USD” as below. 

 
 

7777 The entire condition is summarized in the “Conditions” table at the top of the 
Property Panel for reference. You can add more conditions in the same way, and 
you can activate and deactivate them with the checkboxes in the “Activate” 
column. 

 
 

8888 Click the Save button to close the Property Panel. 

9999 Note in the Pop-up Viewer that the label on the Filter Data Component has been 
updated to say that 1 row was filtered out as expected. 
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10101010 Close the Pop-up window. 

 
 

 

Include the Filter Data Component as a workflow stepInclude the Filter Data Component as a workflow stepInclude the Filter Data Component as a workflow stepInclude the Filter Data Component as a workflow step 

Above, we saw how to make a Component display its user interface in a separate, pop-
up window. Now we’ll expose it to end users in the primary Viewer as a workflow step, 
just as we did with the Table Report Component. 

 

1111 First go to the Builder and open the Filter Data Component’s Property Panel by 
double-clicking on the Filter Data Component icon or right-clicking and selecting 
“Properties…” 

 
 

2222 Change the Viewer Presentation mode to “Standard” and click Save. 
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3333 Now add the Filter Data Component as a workflow step, just as you did with the 
Table Report Component. First double-click anywhere on the white background 
area of the Builder to launch the Property Panel for the Stock Portfolio Analysis 
dashboard.  

4444 Click on the Workflow Steps tab in the Property Panel 

 
 

5555 Click the button titled “Add” at the bottom of the list of workflow steps 

 
 

6666 Proto will automatically add a workflow step for the Filter Data Component.  

 
 

7777 Double-click on the Name field in the table and change the name to “Filter the 
Data.” Then click the “Up” button on the right side of the workflow steps to make 
this step appear before the Table Report on the Viewer. 

 
 

8888 Click Save at the bottom of the Property Panel. 

 
 

9999 Go to the Viewer, and click on the workflow step called “Filter the Data.” Note that 
the Component may not appear in the top left of the Viewer if you moved it while it 
was shown as a pop-up window.  
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10101010 To position and size controls on the Viewer, you can enter Edit Mode and then drag 
and resize them appropriately. 

11111111 To enter Edit Mode, select Tools > Edit Controls from the application menu bar. 

 
 

12121212 The Viewer will turn grey, and the borders of the controls and Components will 
change visually. When you mouse over the border of the Filter Data Component, 
the cursor will change to indicate that you can select and drag the Component.  

 
 

13131313 Click on the Component and drag it up to the top left portion of the Viewer. 
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NoteNoteNoteNote: When you first click on the border of a large Component in Edit mode, the 
Viewer window may auto-scroll to fit the Component in the visible area of the 
Window. When you start to move the Component, this auto-scrolling can creating a 
jerking effect. As you drag the Component up and to the left or resize it so that it no 
longer causes the window to show scroll bars, the jerking adjustments will stop. 

 

14141414 Exit Edit Mode by again selecting Tools > Edit Controls from the application menus. 

 

Click through the workflow steps and note that the Filter Data Component is now 
displayed alongside other steps in the Viewer. 

 

Create FourCreate FourCreate FourCreate Four Interactive Analysis Interactive Analysis Interactive Analysis Interactive Analysis    ComponentsComponentsComponentsComponents    
Now you are going to add four Components that will allow you to experiment with some 
of Proto’s interactive analysis and reporting capabilities. You will follow the same series 
of building steps to insert, connect and configure the Components.  

 

Three of the Components are general purpose, and could work with virtually any 
dataset. The fourth Component is intentionally specialized for portfolio management, 
and in particular the sample portfolio data you are using. When you begin to develop 
analysis, data cleaning and reporting Components that use common data formats, you 
will undoubtedly develop highly specialized functionality that you can then mix and 
match later in new ways. The “Daily Portfolio Summary Views” Component illustrates 
how entire sections of your workflow dashboards can be wholesale repurposed.   

 

AAAAdd dd dd dd four four four four ComponentsComponentsComponentsComponents to the Builder to the Builder to the Builder to the Builder 

1111 Go to the Builder and right-click to browse for a Component to insert.  

2222 Insert the following four Components 

LocationLocationLocationLocation:  ..\ Getting Started Components\Presentation and Analysis 

ComponentComponentComponentComponent: Summarize Data with a Group and Sub-Group.proto 

    

LocationLocationLocationLocation:  ..\Getting Started Components\Presentation and Analysis 

ComponentComponentComponentComponent: Drilldown Bar Graph.proto 

 

LocationLocationLocationLocation:  ..\Getting Started Components\ Presentation and Analysis 

ComponentComponentComponentComponent: XY Graph with Drill Down.proto 

 

LocLocLocLocationationationation:  ..\ Getting Started Components\DEMO - Portfolio Analysis Components 

ComponentComponentComponentComponent: Daily Portfolio Summary Views.proto 
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3333 You can arrange the four new Components and the Table Report on the Builder as 
shown below. 

 
 

    

    

Add Add Add Add thethethethe    four new four new four new four new Components as woComponents as woComponents as woComponents as workflow stepsrkflow stepsrkflow stepsrkflow steps 

1111 Double-click on the background of the Builder, go to the Workflow Steps tab, and 
click the “Add” button four times to add the Components you just inserted. 
 
NoteNoteNoteNote: Some of the Components may have been automatically added as workflow 
steps for you. This can happen when a Component was last saved while it was a 
“step” of another dashboard. As such, you may only have to actually add one or two 
of the Components yourself. 
 

2222 Name the summarization Component “Interactive Summary.”  

3333 Name the drilldown bar graph Component “Drilldown Bar Graph” 

4444 Name the XY graph Component “Drilldown Scatterplot” 

5555 The daily metrics Component should already be named “Daily Portfolio 
Summaries.” 

6666 Reorder the steps if necessary by clicking on the name of the step and using the 
“Up” and “Down” buttons. This will change the order in which the steps appear on 
the Viewer. 
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7777 Click the “Save” button at the bottom of the Property Panel. 

 
 

Go to the Builder and connect the Go to the Builder and connect the Go to the Builder and connect the Go to the Builder and connect the Filter to the Filter to the Filter to the Filter to the Presentation Presentation Presentation Presentation ComponentsComponentsComponentsComponents 

1111 Go to the Builder 

2222 Make the following four Connections, and for now ignore any error messages you 
may get when you connect to the Components.  

FromFromFromFrom:   Filter Data (Generic) 1 

OutputOutputOutputOutput:  Filtered Entryset 

ToToToTo:  Summarize Data with a Group and Sub-Group 1 

InputInputInputInput:  Input Entryset to Summarize  

 

FromFromFromFrom:   Filter Data (Generic) 1 

OutputOutputOutputOutput:  Filtered Entryset 

ToToToTo:  Drilldown Bar Graph 1 

InputInputInputInput:  Set Entryset   

 

FromFromFromFrom:   Filter Data (Generic) 1 

OutputOutputOutputOutput:  Filtered Entryset 

ToToToTo:  XY Graph with Drill Down 1 

InputInputInputInput:  Set Entryset  

 

FromFromFromFrom:   Filter Data (Generic) 1 

OutputOutputOutputOutput:  Filtered Entryset 

ToToToTo:  Daily Portfolio Summary Views 1 

InputInputInputInput:  Daily Portfolio Data  

 

Your Builder window should now look like this. 
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Congratulations! You have finished assembling the Components for this lesson. Now 
return to the Viewer to configure and explore some of the analysis Components you just 
added. 

 

Select File > Save from the application menu bar to save your work. 

 

Explore the AnalysisExplore the AnalysisExplore the AnalysisExplore the Analysis    ComponentsComponentsComponentsComponents    
Click through each of the steps to quickly review what you have built: 

• You are combining two sources of data 

• Filtering out some of the rows 

• And presenting the resulting data in five separate analysis screens 

 

In the remainder of this lesson, you will get a quick introduction to each of the analysis 
Components, but mostly you are encouraged to explore them on your own. 

 

    

The Interactive Summary ScreenThe Interactive Summary ScreenThe Interactive Summary ScreenThe Interactive Summary Screen 

Go to the Viewer and click on the Interactive Summary step to experiment with the 
Summarize Data with a Group and Sub-Group Component. 
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This Component allows you to dynamically create simple aggregation reports. Try the 
following settings and then experiment on your own. 

3333 Set the Group By Listbox to “Analyst” 

4444 Set the Subgroup By Listbox to “LongShortCode” 

5555 Select the “MTD PNL” and “YTD PNL” fields from the summarization columns 
Listbox. 

 

 
 

NotNotNotNoteeee: You can select multiple items in the “Summarize the Totals in These Columns” 
Listbox by holding down the Control key. 

    

NoteNoteNoteNote: You can resize the Table columns by clicking and dragging on the Table header 
between columns. When you position the mouse between columns, the cursor will 
change to indicate that you can begin resizing the column.  

 
 

 

    

    

The Drilldown Bar GraphThe Drilldown Bar GraphThe Drilldown Bar GraphThe Drilldown Bar Graph 

Click on the Drilldown Bar Graph step to experiment with the bar graph analysis 
Component. To configure this Component, you will have to select a numeric column to 
sum over, and a reasonable category to group by for the individual bars.  
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Try the following settings and then experiment on your own. 

6666 Set the Group By Listbox to “Strategy” and ignore any error you get which is due to 
the “sum” column not being numeric. 

7777 Set the Listbox called “Sum the Values in this Column” to “Total PNL” and then try 
“MTD PNL” and “YTD PNL” to compare them.  
 

 
 

8888 Next, click on one of the bars, such as “LS-ConsumerFInSvcs” on the bottom of the 
bar graph to “drill down” into the data that is used to calculate the value of that 
bar.  It’s easiest to see if you scroll the Table at the bottom of the screen over to a 
point so that the column you’re grouping on is visible.  
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The Drilldown Scatter Plot The Drilldown Scatter Plot The Drilldown Scatter Plot The Drilldown Scatter Plot  

Click on the Drilldown Scatterplot step to experiment with the drill down XY analysis 
Component. To use this Component, you select two numeric metrics to compare on X 
and Y axis. For example, you can configure this Component to compare the Year-to-
Date profits with a position’s Market Value to see how well positions are performing 
relative to their inherent risk. If you group by the analyst as well, you can get a sense for 
who is making the best security selections. Then click and drag on the graph to drill 
down to see specific positions of interest.  

 

Configure this Component as follows.  

9999 Set the Pick X Axis Listbox to “Market Value”  

10101010 Set the Pick Y Axis Listbox to “YTD PNL” 

11111111 Set the Group Points by This Listbox to “Analyst.”  

 
 

 

To drill down to specific positions, click and drag on the graph to highlight a group of 
points or an individual point. Note that the rows in the Table show the selected 
positions. 
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Daily Portfolio SummariesDaily Portfolio SummariesDaily Portfolio SummariesDaily Portfolio Summaries 

The Daily Portfolio Summaries show two views of the combined portfolio data in two 
separate sub-steps. One screen shows a summary of P&L winners and rankings, and 
the other screen is an overview of various portfolio exposure metrics. 

MoversMoversMoversMovers    

 
 

Exposure OverviewExposure OverviewExposure OverviewExposure Overview    
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Notice that these two individual Components are grouped together to create a pair of 
analysis screens that are expressed as sub-steps of the “Daily Portfolio Summaries” 
group in the Viewer. You will learn how to group Components in later lessons.  

 
 

Try collapsing this group of steps by clicking on the arrow next to the “Daily Portfolio 
Summaries” label. 

 
 

 

    

Thank You! Thank You! Thank You! Thank You!  

Thank you for your interest in Proto. If you have feedback regarding this tutorial or 
would like to see more training material covering specific topics or questions, please 
email us with suggestions at devcenter@protosw.com or visit the forums at 
http://www.protosw.com/devcenter.  


